aur/PKGBUILD
2022-08-13 16:07:08 +03:00

24 lines
793 B
Bash

# Maintainer: gardenapple <gardenapple@posteo.net>
# Generated by gem2arch (https://github.com/anatol/gem2arch)
_gemname=httpclient-fixcerts
pkgname=ruby-$_gemname
pkgver=2.8.5
pkgrel=1
pkgdesc='Gives something like the functionality of libwww-perl (LWP) in Ruby'
arch=(any)
url='https://github.com/nahi/httpclient'
license=("custom:RUBY")
depends=(ruby)
options=(!emptydirs)
provides=("ruby-httpclient")
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('3466f302f0ca6f89f5c7474c8942f09b87a63487')
package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
}